🍁 Autumn Sale — Tot 70% korting op hosting en domeinen
activeer nu
Veelgestelde Vragen • Apps

Hoe kunnen we de fout van een witte pagina oplossen bij het openen van de Prestashop-administratie?

In dit artikel zullen we u uitleggen hoe u de fout "witte pagina" kunt oplossen bij het openen van het beheer van Prestashop.

Zichten 1303Bijgewerkt 1 anGepubliceerd op 06/07/2018door Sebastian S.

Het probleem van de witte pagina in PrestaShop

Een van de vaak voorkomende problemen na de installatie van een PrestaShop-applicatie is het tonen van een witte pagina wanneer u het beheerdersadres probeert te openen, bijvoorbeeld: domein.tld/administrator (het adres kan variëren afhankelijk van de aanpassingen die tijdens de installatie zijn gedaan).

Oorzaak van het probleem

In het algemeen wordt deze fout veroorzaakt door het feit dat de PHP-directieven opcache.save_comments en opcache.load_comments niet zijn geactiveerd. Dit probleem wordt benadrukt in het error_log bestand in de beheermap. Een voorbeeld uit het foutlogboek ziet er als volgt uit:

PHP Fatal error: Onopgeloste uitzondering 'Doctrine\Common\Annotations\AnnotationException' met bericht 'U moet opcache.save_comments=1 of zend_optimizerplus.save_comments=1 inschakelen.'in /home/USERNAME/public_html/PrestaShop/vendor/doctrine/annotations/lib/Doctrine/Common/Annotations/AnnotationException.php:183

Oplossen van het probleem

Volg de onderstaande stappen om de benodigde PHP-directieven te activeren:

  1. Toegang tot cPanel.
  2. Open Select PHP Version.
  3. Klik op Overschakelen naar PHP-opties.
  4. Activeer de richtlijnen opcache.save_comments en opcache.load_comments door ze op On te zetten.
  5. Druk op de knop Opslaan onderaan de pagina.

Aanvullende informatie

Meer details over het wijzigen van PHP-richtlijnen zijn beschikbaar in de tutorials:

Conclusie

Na het inschakelen van de richtlijnen opcache.save_comments en opcache.load_comments zou het beheergedeelte van de PrestaShop-toepassing toegankelijk moeten worden.

Artikel met een gelijkaardige inhoud

Zichten 1,303
Bijgewerkt een jaar geleden

In dit artikel zullen we u uitleggen hoe u de fout "witte pagina" kunt oplossen bij het openen van het beheer van Prestashop.

Zichten 2,487
Bijgewerkt een jaar geleden

De bekende 500-fout. Voor veel gebruikers vormt dit een groot probleem. In dit artikel vind je alle informatie die je nodig hebt.

Zichten 1,563
Bijgewerkt 2 jaar geleden

Een fout die meerdere oorzaken kan hebben. Als een factor die in het artikel wordt gepresenteerd is geïdentificeerd, zal het probleem worden opgelost.